http://forum.celestialmatters.org/

Black texture error on 3d mesh
http://forum.celestialmatters.org/viewtopic.php?f=4&t=940
Page 1 of 1

Author:  sjohn [ Wed, 25-07-18, 11:24 GMT ]
Post subject:  Black texture error on 3d mesh

I created a torus planet a few months ago. It worked fantastically.

When I bought a new PC, I right away experienced a strange black texture error on the torus mesh.

Here is the error:

Attachment:
torusplanet-black.png
torusplanet-black.png [ 1.54 MiB | Viewed 2124 times ]


Here is the cmod file in cmodview:

Attachment:
cmodview torus.png
cmodview torus.png [ 153.32 KiB | Viewed 2124 times ]


The strange thing is that the problem only appears when I use Open GL 2.0 rendering inside Celestia.

It is working with other Open GL configurations.

The main thing that changed is the previous Radeon RX550 video card to a new Nvidia 1050 Ti card.

Cmodview always displayed the torus mesh with black texture, but it worked anyway in Celestia. Until now.

The problem is not related to any specific Celestia version (1.7 development version Windows 10 64 bit), and it may not be a Celestia bug in my opinion.

How can I fix this problem?

Any suggestions?

Author:  sjohn [ Sat, 28-07-18, 12:50 GMT ]
Post subject:  Re: Black texture error on 3d mesh

OK, I solved it.

For some reason the old dxt5nm normal (bump) texture was corrupted,

I suspect that it was the mipmaps within the texture file. I left them out completely when converting from png format, which basically solved the problem.

Anyway it works now with the new texture.

Attachment:
torus-good.png
torus-good.png [ 1.77 MiB | Viewed 2094 times ]

Author:  ajtribick [ Mon, 30-07-18, 22:11 GMT ]
Post subject:  Re: Black texture error on 3d mesh

Great, glad it's working now!

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/